Umzug erfolgreich abgeschlossen!

3

Vor einigen Wochen hatte Alexander Köplinger bereits auf eine Migration unserer Serverplattform auf eine neuere Version angesprochen, weil unser Provider diese angeboten hat. Der Grund: Windows Server 2003 läuft irgendwann aus der Wartung und der Hoster ist dazu gezwungen seine Kunden auf eine neue Plattform zu migrieren. Wir haben diese Arbeit nun bereits ein paar Wochen vor uns her geschoben, weil einfach die Zeit gefehlt hatte. Der Plan war es eigentlich, am 26.07.2011 die Migration durchzuführen, doch diese musste nun ein wenig schneller erfolgen, deswegen auch die kurzfristige Umstellung gestern und heute.

Unser Provider stellt uns den neuen und alten Server für 7 Tage im Parallelbetrieb zur Verfügung. In den FAQ des Providers steht, dass es je nach Verfügbarkeit auch schon mal ein paar Tage dauern kann, bis der neue Server fertig ist. Dementsprechend hatten wir geplant den Server gestern zu beauftragen und dann mit ihm in der kommenden Woche gerechnet, so das einer Migration am 26.07.2011 nichts im Wege steht. Alex und ich haben zu dieser Zeit Urlaub und hätten dafür Zeit gehabt.

Manchmal kommt es aber anders als man denkt! Der Server war aufgrund der heutigen Möglichkeiten (Virtualisierung) bereits nach 1 Stunde nach Beauftragung fertig und so habe ich begonnen meine privaten Domänen umzuziehen. Dies funktionierte so gut, so dass ich auch das Blog gestartet habe. Auch dort verlief alles ohne Probleme, doch beim Forum stockte es. Der Server brachte immer wieder eine Fehlermeldung: „Der Dienst ist nicht verfügbar“.

Da in den Fehlerprotokollen und auch direkt auf der Webseite nichts zu sehen war, konnte ich dann gestern Nacht die Migration nur abbrechen. Heute morgen funktionierte es dann aber nach zwei Handgriffen. Der Fehler lag bei den IIS 7.5 Anwendungspools. Nach ein wenig hin und her konfigurieren lief es dann und ich konnte die Daten kopieren. Garnicht so einfach, eine 160 MB große SQL Datenbank über das Webinterface zu migrieren. Ich habe schnell gemerkt das es so keinen Sinn macht und habe die Kommandozeile verwendet. Nach dem zweiten Export hatte ich dann auch wirklich alle Daten und konnte sie auf dem neuen Server einspielen.

Zum guten Schluss habe ich noch den DNS Eintrag für forum.home-server-blog.de geändert. Die Replizierung des Eintrags auf alle DNS Server im Web wird eine ganze Zeit benötigen und so bitte ich Euch immer wieder mal vorbei zuschauen und den Browser zu refreshen. Euer Router hält übrigens bis zum nächsten Verbinden auch seine Konfiguration und so macht ein Neustart dort auch Sinn.

Nun hoffen wir, dass alles wieder läuft und freuen uns wieder auf Eure Besuche! 🙂

Über den Autor